[Beremiz-devel] Wrong information shows of PLCOpenEditor

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Beremiz-devel] Wrong information shows of PLCOpenEditor

mail
Hi, 
 PLCOpenEditor runs in Debian 9, some wrong informations show as follow:

$ python PLCOpenEditor.py
(PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
(PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed

How can fix it ?


 



_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel
skv
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Wrong information shows of PLCOpenEditor

skv
Administrator
Hi,

AFAIK these gtk-warning are harmful.
But of course, it'd be nice get rid of them as well.

to fix them, first you have to find gtk widget that issued this warning. This could take time.
Afterwards you need understand, why assertion failed.
As you find widget and understand the code, may happen that the
problem isn't in PLCOpenEditor/Beremiz code, but in some library
underneath. Happy hacking!


On 19-02-25 15:47, mail wrote:

> Hi,
>  PLCOpenEditor runs in Debian 9, some wrong informations show as follow:
>
>
> $ python PLCOpenEditor.py
> (PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
> (PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
>
>
> How can fix it ?

--
Best regards,
Andrey Skvortsov


_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

signature.asc (849 bytes) Download Attachment
skv
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Wrong information shows of PLCOpenEditor

skv
Administrator

I've created ticket in issue tracker for your request, so the problem isn't lost.
https://bitbucket.org/automforge/beremiz/issues/74/fix-gtk-critical

On 19-02-25 11:00, Andrey Skvortsov wrote:

> Hi,
>
> AFAIK these gtk-warning are harmful.
> But of course, it'd be nice get rid of them as well.
>
> to fix them, first you have to find gtk widget that issued this warning. This could take time.
> Afterwards you need understand, why assertion failed.
> As you find widget and understand the code, may happen that the
> problem isn't in PLCOpenEditor/Beremiz code, but in some library
> underneath. Happy hacking!
>
>
> On 19-02-25 15:47, mail wrote:
> > Hi,
> >  PLCOpenEditor runs in Debian 9, some wrong informations show as follow:
> >
> >
> > $ python PLCOpenEditor.py
> > (PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
> > (PLCOpenEditor.py:22314): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
> >
> >
> > How can fix it ?
>
>
> --
> Best regards,
> Andrey Skvortsov


--
Best regards,
Andrey Skvortsov


_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

signature.asc (849 bytes) Download Attachment