[Beremiz-devel] Debugger unexpected Behaviour

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

[Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
Hello,
I have attached the ST code generated by Bremiz. Basically, that is the Function block which takes two numbers and give the output as Quotient, Division Remainder and error. But when I start to debug that code. I have set the input to fixed value so that i can test The expected output should be Quotient = 33 DivRem = 1 and DivError = FALSE.
Debugger show very unexpected result and some time debugger does not show any value.
Any recommendation.
Regards
Suleman Jamil

Cell: +49 157 52992288

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

generated_plc.st (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> Hello,I have attached the ST code generated by Bremiz. Basically,
> that is the Function block which takes two numbers and give the
> output as Quotient, Division Remainder and error. But when I start
> to debug that code. I have set the input to fixed value so that i
> can test The expected output should be Quotient = 33 DivRem = 1 and
> DivError = FALSE.Debugger show very unexpected result and some time
> debugger does not show any value.Any recommendation.Regards

Please attach complete Beremiz project, not just generated st file.

> Suleman Jamil
> Cell: +49 157 52992288
> Email: [hidden email]


--
Best regards,
Andrey Skvortsov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
Hello
Please find the attached file.

Regards
Suleman Jamil

Cell: +49 157 52992288


On Wednesday, November 8, 2017, 3:51:27 PM GMT+1, <[hidden email]> wrote:


On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> Hello,I have attached the ST code generated by Bremiz. Basically,
> that is the Function block which takes two numbers and give the
> output as Quotient, Division Remainder and error. But when I start
> to debug that code. I have set the input to fixed value so that i
> can test The expected output should be Quotient = 33 DivRem = 1 and
> DivError = FALSE.Debugger show very unexpected result and some time
> debugger does not show any value.Any recommendation.Regards

Please attach complete Beremiz project, not just generated st file.


> Suleman Jamil
> Cell: +49 157 52992288
> Email: [hidden email]



--
Best regards,
Andrey Skvortsov
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

BremizTestExamples.tar.gz (172K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
In reply to this post by Beremiz-Devel mailing list



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

BremizTestExamples.tar.gz (172K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
In reply to this post by Beremiz-Devel mailing list
I have sent you but I think email is waiting for approval.

Regards
Suleman Jamil

Cell: +49 157 52992288


On Wednesday, November 8, 2017, 3:51:27 PM GMT+1, <[hidden email]> wrote:


On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> Hello,I have attached the ST code generated by Bremiz. Basically,
> that is the Function block which takes two numbers and give the
> output as Quotient, Division Remainder and error. But when I start
> to debug that code. I have set the input to fixed value so that i
> can test The expected output should be Quotient = 33 DivRem = 1 and
> DivError = FALSE.Debugger show very unexpected result and some time
> debugger does not show any value.Any recommendation.Regards

Please attach complete Beremiz project, not just generated st file.


> Suleman Jamil
> Cell: +49 157 52992288
> Email: [hidden email]



--
Best regards,
Andrey Skvortsov
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
In reply to this post by Beremiz-Devel mailing list
On 17-11-08 17:51, [hidden email] wrote:

> On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> > Hello,I have attached the ST code generated by Bremiz. Basically,
> > that is the Function block which takes two numbers and give the
> > output as Quotient, Division Remainder and error. But when I start
> > to debug that code. I have set the input to fixed value so that i
> > can test The expected output should be Quotient = 33 DivRem = 1 and
> > DivError = FALSE.Debugger show very unexpected result and some time
> > debugger does not show any value.Any recommendation.Regards
>
> Please attach complete Beremiz project, not just generated st file.
>
I don't see any problem. Debug variables have expected values.


--
Best regards,
Andrey Skvortsov



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

Screenshot from 2017-11-08 20-01-42.png (149K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
Hello,
But in my case, it is counting and counting I am sending you the snapshot. Please find the attached file.

Regards
Suleman Jamil

Cell: +49 157 52992288


On Wednesday, November 8, 2017, 6:04:44 PM GMT+1, <[hidden email]> wrote:


On 17-11-08 17:51, [hidden email] wrote:

> On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> > Hello,I have attached the ST code generated by Bremiz. Basically,
> > that is the Function block which takes two numbers and give the
> > output as Quotient, Division Remainder and error. But when I start
> > to debug that code. I have set the input to fixed value so that i
> > can test The expected output should be Quotient = 33 DivRem = 1 and
> > DivError = FALSE.Debugger show very unexpected result and some time
> > debugger does not show any value.Any recommendation.Regards
>
> Please attach complete Beremiz project, not just generated st file.
>

I don't see any problem. Debug variables have expected values.



--
Best regards,
Andrey Skvortsov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

Screenshot from 2017-11-09 10-55-36.png (274K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
Hi Suleman,

On 17-11-09 09:57, beremiz-devel--- via Beremiz-devel wrote:
> Hello,But in my case, it is counting and counting I am sending you
> the snapshot. Please find the attached file.
Sorry, I don't understand what do you mean by "counting and counting".
Could you be more precise?

If you are talking about variables values are not displayed on your
FBD scheme, then the reason is that you haven't opened 'debug
instance' of your POU plc_prg. To do that you have to click on glases
near 'config.resource1.plc_prg_inst....'.

If you are talking about getting wrong results, than I could say that
I have correct results. See screenshot attachment.
Are you sure you use latest matiec? [1]
There were some changes about IL some time ago.

1. https://bitbucket.org/mjsousa/matiec


> Regards
> Suleman Jamil
> Cell: +49 157 52992288
> Email: [hidden email]
>
>    On Wednesday, November 8, 2017, 6:04:44 PM GMT+1, <[hidden email]> wrote:
>  
>  On 17-11-08 17:51, [hidden email] wrote:
> > On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> > > Hello,I have attached the ST code generated by Bremiz. Basically,
> > > that is the Function block which takes two numbers and give the
> > > output as Quotient, Division Remainder and error. But when I start
> > > to debug that code. I have set the input to fixed value so that i
> > > can test The expected output should be Quotient = 33 DivRem = 1 and
> > > DivError = FALSE.Debugger show very unexpected result and some time
> > > debugger does not show any value.Any recommendation.Regards
> >
> > Please attach complete Beremiz project, not just generated st file.
> >
>
> I don't see any problem. Debug variables have expected values.
>
>
 
--
Best regards,
Andrey Skvortsov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

Screenshot from 2017-11-09 13-14-49.png (175K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
I have checked your screenshot and you are getting the right output as expected.
I have downloaded the bremiz and matiec and installed right now and test my program. But still getting the same problem I am attaching the screenshot again.
DivisorIn is set to 20 but its showing 0
DividenIn is set to 20 but its showing 256
and the output result are also wrong.

For debugging
I Build by clicking Hammer button.
Then run the PLC.
then click on the glasses to Monitor the Variables.


Regards
Suleman Jamil

Cell: +49 157 52992288


On Thursday, November 9, 2017, 11:30:27 AM GMT+1, <[hidden email]> wrote:


Hi Suleman,

On 17-11-09 09:57, beremiz-devel--- via Beremiz-devel wrote:
> Hello,But in my case, it is counting and counting I am sending you
> the snapshot. Please find the attached file.
Sorry, I don't understand what do you mean by "counting and counting".
Could you be more precise?

If you are talking about variables values are not displayed on your
FBD scheme, then the reason is that you haven't opened 'debug
instance' of your POU plc_prg. To do that you have to click on glases
near 'config.resource1.plc_prg_inst....'.

If you are talking about getting wrong results, than I could say that
I have correct results. See screenshot attachment.
Are you sure you use latest matiec? [1]
There were some changes about IL some time ago.

1. https://bitbucket.org/mjsousa/matiec



> Regards
> Suleman Jamil
> Cell: +49 157 52992288
> Email: [hidden email]
>
>    On Wednesday, November 8, 2017, 6:04:44 PM GMT+1, <[hidden email]> wrote:

>  On 17-11-08 17:51, [hidden email] wrote:
> > On 17-11-08 13:53, beremiz-devel--- via Beremiz-devel wrote:
> > > Hello,I have attached the ST code generated by Bremiz. Basically,
> > > that is the Function block which takes two numbers and give the
> > > output as Quotient, Division Remainder and error. But when I start
> > > to debug that code. I have set the input to fixed value so that i
> > > can test The expected output should be Quotient = 33 DivRem = 1 and
> > > DivError = FALSE.Debugger show very unexpected result and some time
> > > debugger does not show any value.Any recommendation.Regards
> >
> > Please attach complete Beremiz project, not just generated st file.
> >
>
> I don't see any problem. Debug variables have expected values.
>
>

--
Best regards,
Andrey Skvortsov
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

=?UTF-8?b?U2NyZWVuc2hvdCBmcm9tIDIwMTctMTEtMDkgMTEtNDItMzIucG5n?= (296K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
On 17-11-09 10:47, beremiz-devel--- via Beremiz-devel wrote:
> I have checked your screenshot and you are getting the right output as expected.I have downloaded the bremiz and matiec and installed right now and test my program. But still getting the same problem I am attaching the screenshot again.DivisorIn is set to 20 but its showing 0DividenIn is set to 20 but its showing 256and the output result are also wrong.
> For debuggingI Build by clicking Hammer button.Then run the PLC.then
> click on the glasses to Monitor the Variables.

Very strange.
I still have correct results. I expect that you have not modified your
project since yesterday. I've attached project, that I've used. Try it.
I usually do 'Clean', 'Build', 'Connect', 'Transfer', 'Run'.


 
--
Best regards,
Andrey Skvortsov

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

BremizTestExamples.7z (2K) Download Attachment
signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Beremiz-devel] Debugger unexpected Behaviour

Beremiz-Devel mailing list
Hello
I reinstall again and now it is working. It was also very strange for me.
Thanks a lot. 

Regards
Suleman Jamil

Cell: +49 157 52992288


On Thursday, November 9, 2017, 12:14:12 PM GMT+1, <[hidden email]> wrote:


On 17-11-09 10:47, beremiz-devel--- via Beremiz-devel wrote:
> I have checked your screenshot and you are getting the right output as expected.I have downloaded the bremiz and matiec and installed right now and test my program. But still getting the same problem I am attaching the screenshot again.DivisorIn is set to 20 but its showing 0DividenIn is set to 20 but its showing 256and the output result are also wrong.
> For debuggingI Build by clicking Hammer button.Then run the PLC.then
> click on the glasses to Monitor the Variables.

Very strange.
I still have correct results. I expect that you have not modified your
project since yesterday. I've attached project, that I've used. Try it.
I usually do 'Clean', 'Build', 'Connect', 'Transfer', 'Run'.




--
Best regards,
Andrey Skvortsov
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Beremiz-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/beremiz-devel